Nanoleaf srgbmod plugin was not initiating canvas effects


i Had been having a lot of issue with my nanoleaf and controlling my panels through the API (with the Nanoleaf Desktop App aswell).

The strange thing is when i first got this solution working, it was great for awhile.

Using the Nanoleaf Desktop app, my tiles would temporarily respond after a delay, then become unresponsive, then come back online etc etc.

With the Pico W and SRGBMOD plugin, it wouldnt work at all. Tried a lot of stuff and gave up for awhile.

I put this down to the Flaky Nanoleaf UPNP.

Today i gave my Nanoleafs a Hard reset. The Desktop App was responsive and still is as i type. SRGB would still not take over control of the Canvas tiles…until

I switch on screen Mirroring in the Nanoleaf Desktop app, and this seemed to trigger control from SRGB.

Im now thinking i need to run nanoleaf in mirror mode for SRGB to run my tiles. Time will tell if its stable.

Well, there was some correlation for sure but since a restart the nanoleafs are working with SRGB without the need for nanoleaf desktop in mirror mode. i put it down to Nanoleafs network stack.
I should also point out i created a second SSID on my wifi that ran only 2.4ghz and that mayt have contributing to the issue. Since i took them off that and put them back on the same SSID as other devices (6gHz, 2gHz) it might be better.

Anyone know how to get a consistent connection to Nanoleaf(Canvas)?
I have an ongoing ticket with Nanoleaf.

I’m having zero problems with my Nanoleafs at all, they’re running for hours without a single hicup.

Make sure that you installed the correct version of the Pico core board package like the instructions say.
It has to be 2.4.1, later version cause problems for whatever reason.

Hi FeurSturm,

Its not your solution integration with SRGB, its the Nanoleaf control square itself as i have the same issues with the Nanoleaf Desktop App.

Im going to try another Square to rule out faulty hardware. I also use a Ubiquiti Unifi Wifi 6 WAP, connected to 1GB port on router so there is a little more complexity than just going through the wifi/router. I think the Nanoleaf has issues if devices are not on the same network segment. (desktop is on ethernet, Nanoleaf is on Wifi. etc etc.) I dunno i have not cracked it yet.


Since i updated my Pico W with FeurSturms version 1.1 of the firmware, my Nanoleaf Canvas tiles have been rock solid. Thought i should post that here incase someone is looking for troubleshooting solutions. I still think Nanoleaf has some issues with some of the control Squares in the Canvas line.

@FeuerSturm please add me to the srgb inbuilt wifi testing for Nanoleafs, id love to test that!

You just have to join the test server and grab the “General Release Testing” role, the you will have access to the latest preview release of SignalRGB and th network service plugins.

HI, This is again an issue. Coming out of standby, the Nanoleaf Canvas does not re-establish its connection to SRGB.

I am having to switch the device off then on in SRGB, this gets them going 100% of the time, but SRGB looses it on standby.