Asus TUF RTX 4090 GPU not detected

The Asus TUF mobo, the RAM modules and the cooling fans are all detected, except my Asus TUF RTX 4090, even though SignalRGB supports it (for what I’ve read). I’ve updatet to the latest BIOS and drivers but still no succes.

Can you guys help me with this? Thank you in advance.

Signal RGB does see the card under: ‘Settings’ → ‘Video Settings’


Can you please screenshot the bottom part of this page (SignalRGB needs to be running for that link to work).

Or just type your GPU’s Device and Sub Device IDs in your reply

Hey Vermis,

I’ve put the ID screenshot in the attachments.

Kind regards,

Raymon van Heesch

Try this:

  • Run SignalRGB
  • Use windows run command, paste this in the prompt %localappdata%\VortxEngine\app-2.3.3\Signal-x64\Plugins\Asus\GPUs and click ok
  • copy this file to that folder
  • and then click this

Pls lmk if it works.

Hey Vermis,

Thanks for you response. I’ve tried the things that you mentioned but the


is not recognized by CMD, see the attachment for more information. Maybe I’m doing something wrong?


Hey, you don’t need to paste that in a CMD window
just in run’s prompt

Ok, but how do I open that ‘prompt’? The language in that picture there I can’t read nor understand.

You can invoke the run command window in any language by pressing the windows+r key combination

hey did the file I sent end up working?

Yup, I did the windows + r key combination and used that command, and followed your steps from there on. So thank you!

Do you perhaps have any idea what caused this not to function?

Glad the GPU is working in Signal now :partying_face:

You mean the symbolic file path in command prompt?
That would have worked by typing explorer %localappdata%\VortxEngine\app-2.3.3\Signal-x64\Plugins\Asus\GPUs if your user name is a single word or with quotes explorer "%localappdata%\VortxEngine\app-2.3.3\Signal-x64\Plugins\Asus\GPUs" if it’s more than one word.

But without affixing explorer before the symbolic path the input would not be understood because it’s not a valid DOS file system related command, but if you preffixed with cd You’d navigate to that directory from within the command prompt window, for command line use.