Gigabyte 4070ti Gaming OC 12GB

Hello,

I can’t seem to get SignalRGB to recognize my GPU.

My system specs:
ASUS TUF Gaming Z790-Plus WIFI D4.
Core i9 13900K.
Gigabyte 4070ti Gaming OC 12GB.
(4x) G.Skill F4 - 3200C16 - 32GB TridentZRGB.
Win 11 Pro.

Any help would be greatly appreciated!

Hi,

Can you grab a screenshot of your GPU’s Device and SubDevice IDs? you can find those at the bottom of the Device Information menu under SignalRGB settings. Example:

Here is the screenshot

As far as I can tell that GPU is already prepped to be added to SignalRGB v2.2.33, there’s beta builds you can try (which you can get in Plugin test discord server after grabbing the “General Release Testing” role in the #roles channel there). Please be mindful of the changelogs before installing those.

Okay thank you, just thought it was weird because it worked in my last pc build.

Yeah it’s possible this card was already in 2.2.29, but devs changed how SignalRGB handles some devices in v2.2.31 and they might have forgotten to put it back in. I checked 2.2.31 and 2.2.32 and your IDs aren’t there, but they are in 2.2.33.

2.2.33 Beta Build 1 Did the trick, Thank you vermis!

i have a problem. i tried the thing on discord but i couldnt create a device request thread. signal rgb doesnt see my gigabyte 4070ti gaming oc to

This model is being added on next updates.