SignalRGB wont detect RAM after update to Wn11

Hi, im having problems to make SRGB detect my ram Corsair Venganse RGB PRO SL after update to Windows 11 from Windows 10…

Things i did: (from Discord support, also “restart” is not a solution…)

    • I run the program as admin so many times, from doing right click and quit, also end/kill (signalrgb core) from task manager to run it as admin.
    • I reinstalled the program twice (and delete %temp% files before install).
    • Updated my AsRock Z590 Steel Legend bios for the very last version from AsRock page.
    • Close and Run the program as admin again for 55th time in a row… (bro wtf with discord ppl).
    • Full power cycle?? bro i ate my CMOS battery and this thing still broke…

SignalRGB worked fine on windows 10 but not after upgrading to Windows 11.

Waiting for the support ask me to send logs…

2 days later… Hi!? xDDD

From SignalRGB Official Support:

Issue: “SignalRGB does not Detect my RAM”
Description: my corsair vengance rgb pro sl ddr4 ram not detected after update windows 11 from windows 10… “quit and restart as admin” is not a recomendation at all.

Some things to do:
1- I run the program as admin (from doing right click and quit, also end/kill (signalrgb core) from task manager).
2- Full power cycle?? just throw the PSU to the backyard and ate your CMOS battery… prob this will not fix the problem.
3- Reinstall the program (and delete %temp% files before install).
4- Update motherboard bios for the very last version (use official page of your motherboard).
5- Update all drivers (not windows update only), most important (in intel) is the chipset driver from Intel® Driver & Support Assistant.

You aren’t alone. I had everything running smooth and perfectly on win 11 since I built my rig. it updated last week and I find my ram no longer in my rig lay out, you cant even add or search for ram to add to the layout… Signal RGB is overriding my bios settings as well - I think I just found the fix for that inside signal it self - however my ram is left just displaying stock rainbow fade. No help from signal and super regretting paying for a years sub on this. Im fully updated (amd) still nada

Update 2.2.31 introduced a new SMBus driver (for GPU and RAM control). For that driver to install correctly devs need the program to be run as administrator usually once, sometimes twice. Not needed after that.

Now, If your RAM uses the AURA protocol (G.Skill, Oloy, Teamforce, PNY…) and you are using a Gigabyte motherboard, you might need to install RGBFusion temporarily until developers find a workaround.

Fixed! thank you… RAM is back in sequence.

what was the fix?
I have the same issue. I am running
Corsair Dominator Titanium RGB x 4 (64) Firmware Updated via Corsair
MB is MPG Z790 EDGE WiFi - Bios & Firmware Updated
i9 12th gen
NVIDIA 3090 FE (Updated)
Running 2.3.33-beta+c8aaa27/indicators all green
shows corsair RAM in debugging /device information butt RAM does not show up under my rig and devices.
USP/PCI info is also missing after reinstallation. I am using PRO.

Manually Update Intel Chipset driver

I already did that to the MSI Board Z790 Edge Wi-Fi. I could not load anything until i updated it. I was reading that there is an issue with DDR 5 (RGBs) and Signal, can anyone confirm ? It was 2 years ago.

Reference: Reddit - Dive into anything

is there anyone that can verify this? If it is possible, what is the fix? I have run out of Ideas. Any assistance is welcome. Thank you guys :slight_smile:

not bios, install intel chipset drivers to your windows. google “Intel chipset driver”, first page, option 1 link, click “Chipsets” and select INF chipset driver to download and install.

https ://www. /content/www/xl/es/download/19347/chipset-inf-utility.html

1 Like

Support Message:

Guilherme Candido (SignalRGB)

May 16, 2023, 11:11 PDT

Hello, Ninstrol1

From all that list, the only thing missing is the Chipset driver, was that installed?

Go to and use the auto update tool, it will check for the missing chipset and install.

Thank You,
SRGB Support

Good evening, thanks for your reply. I did both the bios and chipset install and bios.

Thank you,


Nothing is missing from here. Has the 5th gen RAM issue bee fixed yet? Thank you, V/r Brian

@medik73 Send me your latest log, lets see if theres any error there