Razer Naga Chroma detected and showing as working but not lighting up

I’m having no luck getting my Razer Naga Chroma to work with signalRGB even though it’s detected and showing up in the layout. The mouse always defaults to a basic color cycle and won’t change to match everything else (including a corsair k55 keyboard and corsair Vengeance RAM that were difficult setting up because of issues with iCue but are now working flawlessly). I tried installing Synapse and messing with a few different things there and nothing is working. When synapse is open, the mouse will light according to synapse settings but once synapse is closed it always goes back to the same default color cycle. I tried installing the Chroma module in Synapse and setting the RGB to “hide” after a suggestion and that didn’t work. I tried setting the color to transparent and black and also nothing. Even deleted the Chroma modules from Synapse and adjusting lighting directly from the synapse settings without the chroma module and tried a few things there and nothing seems to work to get signalRGB to control the mouse. The mouse will always adjust to whatever settings synapse is set to while synapse is open and back to the default when it’s closed. I’m totally lost at what to try next. As I said, the mouse is detected and showing up in my layout in signalRGB so the program isn’t detecting any issues it’s just not actually controlling it like it should be. Anyone have any ideas?

Can you please enable the device console in the device settings in Signal and check that for errors?

If there’s none at all, we might need some fresh usb captures from Synapse controlling the device.

I’m new to signalRGB and didn’t even realize I could check the console for errors haha. The error code it’s giving me is:

[13:44:49] Error: device.send_report(): HID handle is invalid, confirm that the protocol type selected is HID.

I’ll search this error code and see if I turn up anything now that I have something to go on but if you (or anyone else) knows a solution help would be appreciated. I’ll update if I get it figured out. Thanks!

I’ve forwarded this to the plugin developer to take a look.
Could you try to unplug it and then plug it in again and restart SignalRGB after that in the meantime?

I just tried unplugging and restarting the program, it doesn’t seem to make a difference. From other posts I found through Google it seems like it’s something with the driver or firmware. I updated the driver with no luck though and although I’ve had this mouse for awhile and could possibly be on an older firmware version, I can’t find a firmware update for this particular mouse on the Razer website so I’m assuming that means the firmware hasn’t changed but I don’t know.

Please make sure your mouse is already on firmware v2.02

The linked updater should tell you if you are already on the latest version.

That’s not for my mouse. Mine is the Naga Chroma, not the pro. It’s wired. I looked on Razer’s site for a firmware update and 3 are listed for the Naga but none listed are for the model I have. The one you linked is for a wireless mouse and asks me to plug in the dongle when I run it. Should I try the others and see if one detects and updates this version?

Edit: Just checked Razer site and all 3 firmware updates listed for the Naga are for wireless versions and none will even proceed to check the firmware.

Yeah, that link wasn’t the proper updater for your mouse.

While device dev feuer messaged replies try the latest version of the razer mice plugin.

Run SignalRGB.
Download this file.
Navigate to %userprofile%\Documents\WhirlwindFX\Plugins and copy the downloaded file there.
then restart SignalRGB

That folder didn’t exist. Am I missing a plugin? I created the folder and put the file there and nothing changed.

If you paste %userprofile%\Documents\WhirlwindFX\Plugins in your windows File Explorer address bar or Run command prompt after pressing windows+R it should have taken you to either C:\Users\Your Name\Documents\WhirlwindFX\Plugins or the corresponding folder if you are using OneDrive, and that’s where the downloaded file should go. Folder should’ve already been there so SignalRGB is probably not reading the file I sent and is still loading the default plugin file.

Yeah I was looking in the right place, the folder didn’t exist. It does now because I created it. What does it mean if the folder should’ve been there but wasn’t?

I’m not sure that could even happen so no idea what might have caused the folder to not be where it should.
What SignalRGB version are you on?
Do you now see this notice in the top right corner when you click on your mouse in SignalRGB → Devices?

Ok I figured out the issue there. It was in the OneDrive documents folder even though I don’t use OneDrive. Almost everything else is in “Users\Name\Documents” but about 3 things including this were in the “Users\Name\OneDrive|Documents”. My fault haha. Now that it’s in the correct location, yes I see that user plugin icon now. It’s also showing a battery icon on the picture of the mouse in the device settings and hovering over that says “0%, Draining”

I reckon you not mentioning if the lighting works isn’t a good sign :joy:

Haha no it is not. But I went back to the console with the new plugin loaded and it now contains this line:

[15:32:59] Log: Firmware Version: 1.0

Am I possibly just using an old mouse that isn’t compatible since apparently it’s running version 1.0 and no updates are available on Razer’s site?

The code in the plugin is making the mouse reply with that FW version so that’s what the mouse has on it. Apparently SignalRGB device developer will have to look into it.

Yeah I figured the plugin was calling for the device firmware so that would be accurate. I don’t know when I bought this mouse but I know it’s been quite awhile. Razer site says it only has firmware updates for 2018 and onward, so it’s very possible I bought it before then and this is now considered a legacy device and can’t be updated. Maybe time for a new mouse I guess. I appreciate all the help! If the dev has an answer for me that would be great but if I have to get a new mouse so be it, I’ve gotten my money out of this one lol

Heya I’m the plugin dev. Can you get me a usb capture from Synapse for the mouse? https://docs.signalrgb.com/plugins/capturing-usb-data