Ram stopped working after computer restart

Edit to add some additional info on the PC if it might help.

CPU - 7800X3D
MB - MSI B60 Carbon wifi
M.2 - Samsung 990 Pro
OS - Windows 11 Pro
Ram - G.Skill Trident Z5 neo rgb DDR5-6000 16GB
GPU - Nvidia 4080 Super Founder Edition
PSU - MSI Mag A1000G PCIE5

Hello I need some help with what I should do now when it comes to potentially bugged/soft locked ram. I am not sure how to get this ram to work again and it all started after I set up Signal RGB.

The ram in question is G.Skill Trident Z5 neo rgb DDR5-6000 16GB.

Ok so what kicked this all off is earlier today I installed Signal RGB and after going through and setting up some lighting options I noticed one of the notifications saying that that MSI center and MSI SDK were causing a conflict with the Signal RGB software. After I saw this, I went ahead and I uninstalled MSI center and MSI SDK and restarted my PC.

After I turned my PC off and turned it on again it would start and all the lights and fans would come on but it failed to load into windows or even let me get into bios. It would just sit on a black screen. I noticed the EZ Debug lights on my motherboard were now on (MSI B650 Carbon wifi) and the DRAM and CPU light were both on.

I started to troubleshoot what could be causing this in many different ways. I removed the ram and only used one stick at a time in the A2 slot on the motherboard this did not work. After that I attempted to clear the CMOS and then tried again to use one stick at a time, this also failed. After that I tried to flash the bios but this would not work.

I read in another post on reddit of someone having a similar issue that if there was a issue with your computer’s ram you might need to remove the ram and then try flashing again. I removed the ram and was able to successfully flash the bios with the ram removed. At this point I tested one stick of ram at a time again and put them back into the PC in the A2 slot and tried to start it again. The same issue as before continued, both lights on the motherboard were still on and I was still unable to get the PC to load into bios.

At this point I could not think of anything else I could do. I continued to read other people’s posts online that were having issues similar to mine and found someone saying that the only thing they could do to get their PC to start up again was put in brand new ram. As a last resort I took a trip to micro center and bought another set of the same exact ram that I already have so if I can hopefully fix the bugged/soft locked ram I would still be able to use the new ram assuming I could get it to start again.

After getting the new ram and putting one stick into the A2 slot I was finally able to get my PC to start. After It started I loaded straight into bios to make sure that the bios flash was successful and confirmed I was on the correct version. After confirming this I restarted the PC again and was able to load into windows.

Now that I have been able to get back into windows I disabled Signal RGB on startup and am now hoping someone has a suggestion on what I should do now to test and or fix the ram that was not letting the PC start. At this point I am worried that if I put the ram that was causing the issues back in the PC and restart it might not turn on again.

Any help or suggestion that you might have on what I should do now to try and get the old ram working again would be greatly appreciated.


Have you tried to Power Cycle with the old RAM?

Try following the procedures:

  • Shut down your PC

  • Switch off your PSU (if it does not have a switch, remove the cord)

  • Put the old RAM back in

  • Press your power button several times to get rid of any leftover power

  • Switch on your PSU (or plug in the cord again respectively)

  • Boot up your PC