Ram is not showing up


I have RGB ram that is not showing up in the app? how do I get it to show up under devices? I googled it and saw some people have reseated the modules, did full power cycles, ran as admin and without. I am on the beta branch.

The ram is Gskill Trident z5 DDR5. (TZ5NR).

Thanks for any help in advance.

IIRC several z5 users have reported better reliability in ram detection and control in 2.2.30 beta4 by downloading this file to %localappdata%\VortxEngine\app-2.2.30\Signal-x64\Plugins\Asus and restarting SignalRGB

Are you a mod or dev? Not sure if I want to just accept a js file from a random user lol. No offense. especially from drop box? Just seeing you are a new ish user. If you are just trying to help that is cool. Just assumed it would be a dev or someone replying.

EDIT: SO I went ahead and copied it and made a new js file with it, just in case. But the same ENE_RAM.js is already in there. So it seems I already have it? I compared the two and it has a few lines with LESS data than the one that exists there. startingAddresses = [ 0x70, 0x71, 0x72, 0x73, 0x75, 0x76, 0x77] vs the new one you sent that has some of those taken out?

Second update:

Replaced it and did not do anything. Replace it back with the one that was already in there for now. ?

SO I have not replaced the file with the old one yet, as I tried again after doing something I saw online, installing aura etc, didn’t work, so uninstalled it, did some cycles, nothing really. Stuck the version you sent me (can you still tell me the difference, since it seems that the only change was removing a few hex values?)

Did not change anything :frowning: Well, I went a head and reseated my ram when I did a full power cycle, it works now. lmfao. idk HOW or WHY, as they were in there good (I checked doing this) but never removed them completely. when the Z trident software was working I didn’t think it was an issue, lmao. WIERD but it works now. I may go back to the old file if you think I should, not sure what the removal of the few hex codes above does?

idk the specifics but dev who’s in charge of that now mentioned something about doing less reads off the SMBus registers in detection phase vs the version included in beta4, if it doesn’t cause major issues it’ll probably land in beta5 or even public 2.2.30. It’s less reliable for my DDR4 neos than the one in beta3 but it also applies shutdown color correctly so idk which I’ll keep if I need to choose.

yeah for now it seems to be fine. Not sure how it was working, but yet a reseating fixed it… like weird. especially after doing the full cycle and depleting power and letting it be completely unplugged for a good while. must have been not enough. I even upgraded from 32 to 64 and it already was working just fine without any config. I did have to reorient them in the lay out of course as they are technically different devices but they worked on first boot.