NZXT Function TKL is flickering

Hey everyone!
All my other components are working great but my NZXT Function TKL is flickering.
Some zones on the keyboard work fine, others are just flickering on and off.
I set SignalRGB to close CAM, I disabled all profiles in CAM, I completely closed CAM and I even tried uninstalling it. Nothing helped.
Any suggestions to make the keyboard work properly?

I would check for Services that might be running, I had a similar, also found I had "Armory Crate’ enabled in my Bios “Asus mother board” I disabled this in bios, then uninstalled anything every thing Asus, including Nzxt Software, Asus Lighting service, any core iCue stuff, and the flickering eventually stopped. Also if you have a Light strip or a Fan or something that is Daisy Chained, and has the Wrong number of LEDs like it is a 10 LED Strip but you have 12 or 8 I have seen the edges flicker. Just throwing suggestions at you I did resolve all my flicker eventually.

Like I said, I uninstalled CAM. So all related services should be gone. And all other LEDs (an aRGB lightbar, daisy chained light strips, 3 Corsair fans and 4 sticks of RAM) are all working properly.
I rebooted after every step and the flickering still persisted.

on the item that’s flickering, remove that and add a custom LED bar make it like 40 long, then go paint that strip till you see exactly how many LEDs are really in it.
also as a custom strip even larger than it is, does it still blink?
I took my blinking strips that were 20 LED’s long, made them a 40 strip custom LED, they stopped blinking, then I painted them 1 LED at a time to figure out exactly how many LEDs were really there, then created a custom strip with the correct # of LED"s and they work now without blinking. I am only making suggestions and sharing what worked for me. I don’t work for SignalRGB.

We will be releasing an fix on the beta branch, be sure to enable beta on the settings and restart Signal.

Sorry to reply so late but it’s still flickering. It’s happening less often but it still does flicker.

Just got the update to signalrgb@2.3.87+ce94773f and it’s still flickering.