Mystic Light / Ledkeeper2 / Mystic Light

Hey all - I was searching for the answer to ledkeeper2 /lightkeeperservice preventing SignalRGB from controlling certain RGB (ram on my motherboard). I didn’t find answers other than removing Mystic Light and running the cleaner.

Here’s what I did to resolve this without uninstalling Mystic Light.

Go to task manager, find ledkeepr2 running and right click it for file location. Open file location, right click Ledkeeper2.exe and rename it to Ledkeeper2bak.exe. Do the same thing next (same folder) for Lightkeeperservice since that will be the other file it wants to run, even if MSI Center is disabled in starup. I restarted my PC and ALL my LED’s were synced for the first time.

I don’t use Mystic light for anything else but found I COULD NOT get anything but my RAM working for LED’s without it. So now, everything works at startup, there’s no prompt to close ledkeeper2 / lightkeeperservice to let SignalRGB take over, and all appears well.

Your mileage may vary - but now there’s another option when you search if you want to try it.