Fans stuck on white after uninstall

Hello I tried signal RGB to unify my builds RGB but didn’t have enough time to configure as needed so I uninstalled it. After the uninstall and reboot all my fans are stuck on white and a light strip is 1/2 lite. Everything else seems to be working fine CPU & GPU blocks, Mobo and RAM.

Before I installed I had uninstalled ICUE and Razer and Polychrome (AsRock) software as recommended. All devices connected to the mother board (AsRock B550 Taichi w/latest bios) were still running RGB Rainbow effect even after the uninstalls. I assume since they are all attached to the motherboard 3 pin ARGB headers and the BIOS was set to run rainbow. One exception a LED strip on the case (Phanteks G500A) was running static red green and blue evenly spaced across the strip prior to installing Signal RGB. Now as mentioned above it is 1/2 lite.

This is a new build clean install of windows. It is my hope I do not have format and reload to fix. Is there a way to clean up this mess?

Follow these steps to do a full power cycle:

Please read and re-read the directions carefully, if you are confused please ask for clarification!


  • shut down your PC
  • switch off your PSU (if it does not have a switch, remove the cord)
  • press your power button several times to get rid of any left over power
  • switch on your PSU (or plug in the cord again respectively)
  • boot up your PC

Ya that didn’t help
I want to reiterate now all work fine before I installed Signal RGB and attempted to run through set up
So I started unplugging all those stuck on white.
Now my GPU is half lite CPU block doesn’t display red without some blue lights lite
All I have connected now is:

  1. GPU Block XFX speedster zero EK 6900XT in B550 Taichi 5v ARGB header two (not recognized during SRGB setup)
  2. CPU Block XSPC Raystorm Edge in B550 Taichi 5v ARGB header 1 (not recognized during SignalRGB setup)
  3. GSkill Royal-Z Memory (displays perfect RGB rainbow) ( was recognized by S-RGB)(no attempts were made to adjust)
  4. Motherboard VRM cover/chipset HS/ board edge (all displays perfect RGB rainbow) ( was recognized by S-RGB) (no attempts were made to adjust)
  5. Both RGB 12v and A-RGB 5v headers of the B550 Taichi 4 total were recognized by S-RGB set up.

With the exception of 3&4 above the unrecognized by S-RGB software are what I’m having issues with.
I attempted to add GPU block by guessing number of leds and attempted layout changes and saved them but before watching the video on how to correct number of leds selected I ran out of precious weekend time and uninstalled.
In further attempts to correct I deleted the WFX whirlwind <<<< ? folder created during S-RGB set up and reinstalled ICUE, Phantom and Razer software. None helped
I should also mention I tried both CPU blocks individually alone and combined in each A-RGB header.
Each time I tried your trick unplugging and pressing the case on button several times.
I’m running Win11 and App data is no longer accessible or I would go in there to delete what ever is left behind and I would search for registry entries to delete it if I knew where to look.

wow I typed a rather lengthy post and it disappeared after clicking reply
this has become a nightmare
Your trick didn’t work

I don’t understand why the post is hidden
I’d prefer any help I can get

I will attempt again tomorrow this is not resolved

Your post was flagged as potential spam for whatever unknown reason, it’s shown now.

You can try the unofficial uninstall batch script,
that should nuke any left overs of SignalRGB:

If that, followed by a full power cycle doesn’t help,
official support and/or a developer will have to have a look.

After uninstalling signalrgb, you need to install and configure other control software to put your devices back in rainbow mode if that’s where you want them to be. Asus aura can do that for the mobo headers, you need all the control software for each of your other products to do this independently.

I appreciate the reply Matt I did that and something is still stuck. Also did the power disconnect several times as well. Even tried the most recent bios update for the motherboard. I found folders left over in the root drive after uninstall so it is not a thorough uninstall. Win11 doesn’t let you mess with the AppData folder or I would go in there and clean it up. There should be a cleanup utility to wipe all data entries in AppData and registry. Haven’t searched the registry yet but it would be helpful to know where to look. The more I think about this I think there is an issue with the motherboard 3 pin addressable headers but that doesn’t explain why all worked before S-RGB install. I guess the only thing I can do at this point is format and reload windows as it’s the only thing I haven’t tried

edit I did not see FeuerSturm’s post above I will try that.

I ran the Uninstall exe after unblocking thru properties and running as administrator after following your link. Shut down power off 10 minutes (unplugged) pressed the pwr button several times immediately after unplugging and after 10 (shower that time of day) no changes still 1/2 leds working on the GPU CPU has all leds lite but red is absent on both except for briefly on both with other colors at the same time. No transitioning to full red or even close in Rainbow mode on the A-RGB 3 pin headers of the motherboard.

Is there an A-RGB controller that doesn’t require the mobo header

ARGB Controllers

  • allow you to individually control the lighting of all connected fans/strips
  • in general they are connected via internal USB 2.0 header to your mainboard. (your mainboard does not have to be a supported device in this case!)

These generic ARGB Controllers that are using the default 5v 3pin ARGB plugs are supported:

Just to clear this one up a bit it was a motherboard issue and I have since replaced it and simplified the build overall with fewer competing software installs. It may too have been how I connected The case controller to sata power and connected the 3-pin ARGB to the Chroma which also had separate sata power applied. Some lights/leds literally burnt out and the mobo argb headers ceased to work but this was how I was told to do it on Reddit by a handful of people. All I can say is steer clear of advise found there.