Corsair Virtuoso SE not able to be controlled by SignalRGB

Hello! I know that there was a similar post about the XT headset not functioning, and I did see the fix that included the beta update – however, this has not really seemed to work for me. I’m enrolled in the beta, have completely closed iCue, etc., however, this issue still persists. I’m getting a similar error message as the XT post:

[Tue Dec 12 20:41:12 2023] Error - Error: device.write(): HID handle is invalid, confirm that the protocol type selected is HID.

I saw in a different post for a very different device that the customer support gave them a file to put into their plugins folder – I was wondering if that would help? And if so, where would I find it? I haven’t been able to search for it nor find it online so far. Additionally, the headset seems to be defaulting to white when iCue is closed, yet I cannot change the color from there. Thank you!

Can you try run Signal as admin? When a Handle isn’t available, that basically means not all endpoints are present or has been detected, running as admin can fix that.

Right, I forgot to mention that other issue. Apologies! When I run it as administrator, it doesn’t seem to actually give Signal admin permissions. The admin box is checked in properties (I’ve tried unchecking/rechecking it again). I’ve done restarts, reinstalls, and tried using powershell as well — yet it always shows that it doesn’t have full administrator rights. Is there some setting that I’m missing?