Corsair Mouse M65 Pro is not working

Hello, :slight_smile:

im using SignalRGB for the first time and i love it. The only issue is my Corsair M65 Pro. It doesnt work and the consol tells me this:

“device.write ( ) : WriteFIle: (0x00000001) invalid function.”

Can anyone help me with it?

Try this:
1- Run SignalRGB
2- Explore %userprofile%\Documents\WhirlwindFX\Plugins
3- Put this file in that folder
4- Then click this → signalrgb://app/restart

let us know if that works

1 Like

Hey Vermis,

thank you. It worked :slight_smile:

1 Like

Awesome :partying_face: , any chance I could abuse your kindness and ask for what mouse firmware version you’re on? It’s probably listed in iCUE

Hi team,
I just signed up for the app and I’m amaized at how well it works!
I’m just having an issue with the mouse. My mouse is the M65 Pro Wireless but it’s being detected as a Corsair Sabre RGB PRO Wireless. While it works, the colors displayed don’t match the effect in use.
I tried the fix suggested earlier, copying Corsair_M65_Pro_Interface_1_Mouse.js into Plugins folder, with same result.
Have latest firmware via iCUE and MB bios.
Uninstalled all RGB software.

Can I get this uploaded again?

Link is dead and I’m encountering the same issue.

Hey, that plugin is no longer there because was incorporated into an aggregative plugin, which might be the issue, try this other file, same procedure.

And pls lmk the result.

EDIT:got preliminary results from another source, it didn’t work for them, can you confirm?

EDIT 2: The other user whose m65 pro had stoppped working after last update got it fixed by plugging the mouse into different USB ports. Have you tried that?