About B550 Vision D-P

Has anybody here has a problem with SignalRGB not recognizing the motherboard itself eventhough there’s this ARGB pin in it and a connected peripherals? If you’ve found any solution, any help would be much appreciated. Thanks

Make sure that you are using the latest BIOS and chipset drivers and that you have run SignalRGB with admin rights at least once.


Thanks for the reply. I believe I have the most recent bios but haven’t tried running SignalRGB with admin rights. I’ll do that and give an update if it fixes the problem. Thanks

Nope, tried updating and running SignalRGB with admin rights but still it doesn’t find my mobo, even my RTX 3070ti is not showing here. Any solutions out there or is my mobo defective? Thanks

Can you please upload the latest log file larger than 5kb together with a screenshot of the “Device Information” page in Signal (click the settings cog bottom left)?

On that page there’s a “logs” button at the top that opens the log folder.

Furthermore make sure that RGBFusion is enabled in your bios settings.

Hello again! and Thanks for helping me out. Here’s what your asking. Hope this helps with finding a solution.

Here’s a link for the log file.

Your BIOS is not the latest version and your chipset drivers are extremely outdated as well.
You are running BIOS F15a while F15 is the latest (that should not be the problem, but could be).
You’re running chipset drivers v3.10.22.706 while the current version is v4.11.15.342 (most likely the problem).

Furthermore check your BIOS settings for RGBFusion, your mainboard doesn’t show up in the “Device Information” at all, which it should.

So I’d start with installing the latest chipset drivers (needed anyways), then checking the BIOS
options and then updating BIOS.

oops wait that was dated yesterday. Here’s the latest log file as well as the screenshot. Thanks

You’re still running the old AMD Chipset Version in that log.

Yep, just installed the newer version of the chipset just now, then looked for the RGBfusion in BIOS and can’t seem to find it in the BIOS. Would it help if I installed RGBfusion software instead?

In “Advanced Mode” check “Settings” → “Miscellanous” and check what settings you have
for “LEDs in System Power On State” and make sure that’s “ON”.

There might be some more related settings.

You can try RGBFusion, if it works with that, it should work with Signal as well.

Yes I did turned ON those LED settings in the BIOS as well. Installed RGB fusion just now but still a no-go for my motherboard. Anyways, thanks for the help on this matter. I might just as well give up on this mobo and change it to a much better one. Thanks a lot for the time and effort.

The mainboard not working with RGBFusion either is alarming, if you checked all
settings in BIOS and everything is ON that should be enabled, I’d try to return it.

Yeah but warranty is already out of the question since this was I think 1.5yrs old I guess? Anyways, maybe it’s time for me to change mobo hehehe

You can still keep the mainboard and buy a supported lighting controller
like the Razer Chroma ARGB Controller and connect your led strips and fans to that instead.

As for your GPU, what exact model is it? If it’s on the list of supported devices, but not showing
up it might just be a revision that is not added yet.